Is it just me or has the site been sluggish lately?

Feedback on anything site related. Forum issues and the Traders to Avoid list
User avatar
Losbot
Almighty Member
Posts: 4320
Joined: Sun Jul 13, 2014 8:59 am
Location: South Florida

Is it just me or has the site been sluggish lately?

Postby Losbot » Mon Mar 15, 2021 11:35 pm

The last couple of weeks, I've noticed the sight has had long delays before pages load. Just sits there spinning for a while.

Traceroutes look OK:

Tracing route to pcabusers.org [204.11.19.35]
over a maximum of 30 hops:

1 * * * Request timed out.
2 1 ms 1 ms 1 ms lightspeed.miamfl.sbcglobal.net
3 26 ms 26 ms 33 ms 108-254-180-1.lightspeed.miamfl.sbcglobal.net [108.254.180.1]
4 * * * Request timed out.
5 33 ms 31 ms 31 ms 12.242.116.11
6 * * * Request timed out.
7 39 ms 38 ms 43 ms be3401.ccr22.mia01.atlas.cogentco.com [154.54.47.29]
8 54 ms 54 ms 54 ms be3570.ccr42.iah01.atlas.cogentco.com [154.54.84.1]
9 57 ms 55 ms 57 ms be2443.ccr32.dfw01.atlas.cogentco.com [154.54.44.230]
10 56 ms 55 ms 54 ms be2939.rcr21.dfw04.atlas.cogentco.com [154.54.6.114]
11 56 ms 56 ms 55 ms be3795.nr51.b028597-0.dfw04.atlas.cogentco.com [154.24.61.202]
12 56 ms 57 ms 57 ms 38.140.239.18
13 56 ms 57 ms 56 ms border5.ae2-bbnet1.dal006.pnap.net [216.52.191.109]
14 59 ms 58 ms 57 ms bdhg10g-11.edge1.dal006.pnap.net [63.251.32.62]
15 55 ms 54 ms 54 ms c2-1.dal.innoscale.net [204.11.19.35]

Trace complete.
------------------------------------------

Image

User avatar
FlyingPenguin
Flightless Bird
Posts: 31194
Joined: Wed Nov 22, 2000 11:13 am
Location: Central Florida
Contact:

Re: Is it just me or has the site been sluggish lately?

Postby FlyingPenguin » Tue Mar 16, 2021 12:06 am

I notice issues late at night usually, not during the day. Like right now answering you it's sluggish. I can put a ticket in and see what happens.
- "Great spirits have always encountered violent opposition from mediocre minds." - Albert Einstein

Image

User avatar
Executioner
Life Member
Posts: 9477
Joined: Wed Nov 22, 2000 11:34 am
Location: Woodland, CA USA

Re: Is it just me or has the site been sluggish lately?

Postby Executioner » Tue Mar 16, 2021 10:31 am

FlyingPenguin wrote:Like right now answering you it's sluggish
There is the answer! Dude...cut back on the pOrn download. ;)

User avatar
FlyingPenguin
Flightless Bird
Posts: 31194
Joined: Wed Nov 22, 2000 11:13 am
Location: Central Florida
Contact:

Re: Is it just me or has the site been sluggish lately?

Postby FlyingPenguin » Tue Mar 16, 2021 11:01 am

I half suspect it might be a PHP limiter. It used to happen on the old forum software and it used to happen all the time on some websites I created for clients that heavily used a PHP script as a text based database. Some hosts will temporarily throttle you if your PHP usage spikes. That, or it's a phpBB issue. On the off chance they have us on a creaky old server with a bad NIC or a failing HDD, I'll put in a ticket and see what they say.
- "Great spirits have always encountered violent opposition from mediocre minds." - Albert Einstein

Image

User avatar
FlyingPenguin
Flightless Bird
Posts: 31194
Joined: Wed Nov 22, 2000 11:13 am
Location: Central Florida
Contact:

Re: Is it just me or has the site been sluggish lately?

Postby FlyingPenguin » Tue Mar 16, 2021 5:29 pm

Okay, host did some digging through the logs for me (great support from these guys). He thinks the reason for the occasional lag is that our version of the BBS uses a deprecated version of PHP (5.6) and performance on the old version is known to be a lot slower than the latest 7.x version.

He did bump up the assigned RAM which may help as the old PHP was a RAM hog.

Other than that, he recommends upgrading to the latest version of phpBB, but I know I'm not up to it, and not sure if Genom is still around or would have the time for it.

Let's see if the RAM helps and maybe we can get by.

Here's the email he sent me:

Bob,
I looked at the account. The time you report is when backups are running on the server, so there is some increased load.

But there are also some issues that you/us can work through to improve performance. Here is what I have found:
1) the account is still running on PHP 5.6. This is an EoL version of PHP, and performance of this version is 2-3X slower than the current supported versions of PHP (7.3 and 7.4). I know this can be a big ask if your vendor doesn't frequently update their software, but if you have a version of your phpbb3 software that can run on those versions (or even PHP 7.1 or 7.2) you are going to leverage a massive performance improvement - a bigger improvement than I can get for you by anything done on the server.
2) RAM on the account - PHP is set to 256MB on this account, which is standard and should run anything, but I have provisionally given it 368MB to see if that helps (newer PHP versions at mentioned in #1 above have lower RAM requirements).
3) I didn't see anything on the account where you were tripping the account-level limits imposed by CloudLinux

Let us know how we can help, but I would bet that the most efficient upgrade would be installing the latest phpbb3 version, and then having us move up your PHP version and testing how that goes.

I haven't heard of any reports of routing problems, but if you have a user having problems, please ask them to provide a traceroute and we would be happy to look into that.

Sincerely,
--
Brent Presley, M.D., Ph.D.
Co-Founder and Chief Business Officer
Innovative Scaling Technologies Inc.

- "Great spirits have always encountered violent opposition from mediocre minds." - Albert Einstein

Image

User avatar
Losbot
Almighty Member
Posts: 4320
Joined: Sun Jul 13, 2014 8:59 am
Location: South Florida

Re: Is it just me or has the site been sluggish lately?

Postby Losbot » Wed Mar 17, 2021 12:56 pm

What's this running on? If Genom doesn't have time, I'm willing to do some research, backup everything and update software.
------------------------------------------

Image

User avatar
Losbot
Almighty Member
Posts: 4320
Joined: Sun Jul 13, 2014 8:59 am
Location: South Florida

Re: Is it just me or has the site been sluggish lately?

Postby Losbot » Wed Mar 17, 2021 12:56 pm

Executioner wrote:
FlyingPenguin wrote:Like right now answering you it's sluggish
There is the answer! Dude...cut back on the pOrn download. ;)


LMAO That must be it.
------------------------------------------

Image

User avatar
FlyingPenguin
Flightless Bird
Posts: 31194
Joined: Wed Nov 22, 2000 11:13 am
Location: Central Florida
Contact:

Re: Is it just me or has the site been sluggish lately?

Postby FlyingPenguin » Wed Mar 17, 2021 1:38 pm

We.re tuning phpBB 3.1.7. They're up to 3.3.3 now:
https://www.phpbb.com/

Instructions here: https://www.phpbb.com/support/docs/en/3 ... upgrade31/

If you're up for it, I can give you the server and admin credentials.

I download backups the home directory and MySQL database once a month, via the host's CP, and we can do that right before any upgrade.

I have found one issue that generates a GZip compression conflict error that I can see at the top of the BBS CP. Not sure if that's causing the hiccups. Basically if the server has the GZip library installed (apparently ours does), you need to disable the built in GZip compressor in phpBB, otherwise the BBS tries to recompress already compressed files. I was going to do that later.
- "Great spirits have always encountered violent opposition from mediocre minds." - Albert Einstein

Image

User avatar
FlyingPenguin
Flightless Bird
Posts: 31194
Joined: Wed Nov 22, 2000 11:13 am
Location: Central Florida
Contact:

Re: Is it just me or has the site been sluggish lately?

Postby FlyingPenguin » Wed Mar 17, 2021 1:50 pm

Okay turned the compression off and that cleared the error. Server is running on Apache BTW.

Image
- "Great spirits have always encountered violent opposition from mediocre minds." - Albert Einstein

Image

User avatar
Losbot
Almighty Member
Posts: 4320
Joined: Sun Jul 13, 2014 8:59 am
Location: South Florida

Re: Is it just me or has the site been sluggish lately?

Postby Losbot » Wed Mar 17, 2021 3:57 pm

Sure. PM the info and I'll look through it.

I'm coincidentally in the CP of my email server's VM, as I'm working on migrating that email server software from 32bit to a new VM running the 64bit version of the server and moving the mail store to the new box as well. Then updating DNS to point to the new one. Fun fun.
------------------------------------------

Image

User avatar
FlyingPenguin
Flightless Bird
Posts: 31194
Joined: Wed Nov 22, 2000 11:13 am
Location: Central Florida
Contact:

Re: Is it just me or has the site been sluggish lately?

Postby FlyingPenguin » Sun Apr 11, 2021 9:08 am

Support reminded me that the version on PHP we're using is going to be end of life soon, so we should probably upgrade when we can. I make backups, and they say they can also roll back the server image if something goes wrong.
- "Great spirits have always encountered violent opposition from mediocre minds." - Albert Einstein

Image

User avatar
Losbot
Almighty Member
Posts: 4320
Joined: Sun Jul 13, 2014 8:59 am
Location: South Florida

Re: Is it just me or has the site been sluggish lately?

Postby Losbot » Mon Apr 12, 2021 10:28 am

Let's plan accordingly and update. I've still been seeing some lag in the evening hours.
------------------------------------------

Image


Return to “PCA Feedback & Forum Issues”

Who is online

Users browsing this forum: No registered users and 1 guest